» » » » » » Cerinţe minime pentru instalarea Joomla!

Cerinţe minime pentru instalarea Joomla!

posted in: Joomla 0

Pentru a instala şi folosi Joomla! trebuie să dispuneţi de un server web complet operaţional (optim, Apache), o bază de date (optim, MySQL) şi limbajul scripting de server PHP, împreună cu modulele specifice activate în PHP pentru MySQL, XML, şi Zlib funcţional, printre altele.
Deşi comunitatea va face întotdeauna tot ce ăi stă în puere pentru a te ajuta, Joomla! nu este un server web şi depinde de tine să ai un server web complet funcţional şi compatibil.

Joomla! este dezvoltat şi a fost testat în special pe servere Apache versiunile 1.3.x + şi 2.x +.
Deşi sunt toate şansele să meargă şi cu alte sisteme, precum Windows IIS, acesetea nu sunt în mod necesar suportate complet de către comunitatea de suport tehnic.
Din păcate acelaşi lucru se poate spune pentru baza de date, unde MySQL este principala alegere dar se pot folosi şi alte tipuri de baze de date cu configuraţia necesară, care însă sunt mai puţin suportate în prezent. Această situaţie se va rezolva cu timpul.

Versiunile minime necesare ale diferitelor părţi constituiente ale componentelor acestor servere sunt următoarele:

Software Cerinţa min. Recomandat Ultimele opţiuni Sit web
PHP 4.3.10 4.4.7 5.x series PHP
MySQL 3.23.x or above 5.x series MySQL
Apache 1.3 or above 2.2 series Apache
mod_mysql
mod_xml
mod_zlib

Trebuie să te asiguri că ai MySQL, XML, şi funcţionalitatea Zlib este activată în instalarea PHP. Aceasta este controlată de fişierul php.ini.

Nu folosiţi PHP 4.3.9, PHP 4.4.2 sau PHP 5.0.4; aceste versiuni au buguri cunoscute care vor interfera cu instalarea lui Joomla! Ele au fost o problemă şi pentru Zend Optimizer Versiunea 2.5.10 pentru PHP 4.4.x. Trebuie să soliciţi gazdei să actualzeze la o versiune ulterioară cât mai repede, dacă este posibil.
Dacă ai probleme cu Joomla! pe alte versiuni ale acstor programe de server verifică fişierele de logare, întrucât acolo vei găsi adesea indicii bune privind cauzele problemeleor. Dacă ai o problemă anume identificată de tine, trebuie să vorbeşti cu firma de găzduire rugându-i să actualizeze programul afectat.

MySQL 6.x nu este încă suportată.

Există discuţii în curs despre eventualele probleme datorate întregii serii de versiuni PHP 4.3.x. S-a descoperit că cele mai bune şi mai consistente rezultate sunt obţinute cu seriile de versiuni PHP 5.x.

Joomla! a fost testat cu succes pe multe variante cu cele trei principale SO pentru Windows, Linux, Apple Mac OSX. S-ar putea să meargă bine şi pe alte platforme, dar acele opţiuni sunt mai puţin documentate.

Joomla! este de asemenea testat şi folosit în mod frecvent cu ajutorul principalelor browsere precum IE6 +, Firefox 1.5 +, Safari, şi Opera, dar s-ar putea să meargă şi pe alte tipuri de browsere.

Au existat probleme binecunoscute cu IE6 şi anumite setări de afişare CSS în prezentarea template, de care este bine să se ţină cont.

Author: Andy Wallace Joomla! User Documentation Team Version 0.5 30 October 2007 – Traducere de Nicolae Sfetcu.

Leave a Reply

Your email address will not be published. Required fields are marked *