» » » » » » Drupal standard

Drupal standard

postat în: Drupal 0

Druplicon.vector

Drupal de bază este instalarea standard a lui Drupal, care poate fi extinsă opţional prin contribuţia altor dezvoltatori. În configurarea implicită a lui Drupal, conţinutul sitului poate fi dezvoltat cu ajutorul utilizatorilor înregistraţi sau anonimi (în funcţie de preferinţele administratorului), şi poate fi făcut accesibil pentru vizitatori cu ajutorul unui mare număr de criterii selectabile, inclusiv date, categorii, căutări, etc. Drupal de bază include şi un sistem taxonometric ierarhizabil, care permite categorisirea conţinutului sau folosirea tagurilor cu ajutorul cuvintelor cheie pentru un acces mai uşor.[1]

Drupal menţine un fişier detaliat cu schimbările caracteristicilor de bază actualizate după fiecare versiune.[2]

Module de bază

Drupal de bază include "module de bază" care pot fi activate de către administrator pentru a extinde funcţionalitatea sitului web de bază.[3]

Distribuţia Drupal de bază oferă mai multe opţiuni[3], inclusiv:

  • Statistici de acces şi autentificare
  • Funcţii de căutare avansate
  • Cache şi limitarea opţiunilor pentru îmbunătăţirea performanţelor în sarcină
  • Comentarii, forumuri, şi sondaje
  • URL-uri descriptive (de exemplu, "www.exemplu.ro/produse" în loc de "www.exemplu.ro/?q=node/432")
  • Sistem de meniu pe mai multe nivele
  • Suport multi-sit[4]
  • Creare şi editare de conţinut multi-utilizator
  • Suport OpenID
  • Fluxuri de distribuţie RSS şi agregator de surse
  • Notoficări pentru actualizările noi şi de securitate
  • Profile utilizatori
  • Restricţii de control la acces (roluri utilizatori, adrese IP, email)
  • Instrumente de lucru în proiecte  (etape şi acţiuni)

Cerinţe minime de sistem:

  • Server web

– Apache este recomandat, dar Drupal poate fi configurat şi folosind Microsoft IIS

  • Versiune PHP

– Recomandat: PHP 5.2 sau mai nou, Minim: PHP versiunea 4.3.5 sau mai nou

  • Server pentru baza de date

– Recomandat: MySQL 4.1 sau MySQL 5.0, PostgreSQL 7.4 sau mai nou

  • Browser web

– Internet Explorer 6.x şi mai nou, Firefox 2.x şi mai nou, Opera 7 şi mai nou, Safari 1.x şi mai nou şi Camino 1.x şi mai nou.

Note

(Traducere şi adaptare din Wikipedia sub licenţa GNU)

Aveţi nevoie de un webmaster? Click AICI. Tel. 0745-526896

Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile obligatorii sunt marcate cu *